home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / hostap-driver-0.4.7 / hostap-driver-0.4.7.ebuild < prev    next >
Text File  |  2006-05-02  |  3KB  |  117 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap-driver/hostap-driver-0.4.7.ebuild,v 1.4 2006/03/26 16:06:24 brix Exp $
  4.  
  5. inherit toolchain-funcs eutils linux-mod
  6.  
  7. DESCRIPTION="Driver for Intersil Prism2/2.5/3 based IEEE 802.11b wireless LAN products with injection patch"
  8. HOMEPAGE="http://hostap.epitest.fi"
  9. SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
  10. LICENSE="GPL-2"
  11.  
  12. KEYWORDS="~amd64 ppc x86"
  13. IUSE="pcmcia"
  14. SLOT="0"
  15.  
  16. RDEPEND=">=net-wireless/wireless-tools-25"
  17.  
  18. BUILD_TARGETS="all"
  19. MODULESD_HOSTAP_DOCS="README"
  20. MODULESD_HOSTAP_CRYPT_WEP_ENABLED="no"
  21. MODULESD_HOSTAP_CRYPT_TKIP_ENABLED="no"
  22. MODULESD_HOSTAP_CRYPT_CCMP_ENABLED="no"
  23.  
  24. CONFIG_CHECK="!HOSTAP NET_RADIO"
  25. ERROR_HOSTAP="${P} requires the in-kernel version of the hostap driver to be disabled (CONFIG_HOSTAP)"
  26. ERROR_NET_RADIO="${P} requires support for Wireless LAN drivers (non-hamradio) & Wireless Extensions (CONFIG_NET_RADIO)."
  27.  
  28. pkg_setup() {
  29.     linux-mod_pkg_setup
  30.  
  31.     if kernel_is ge 2 6 15; then
  32.         ewarn
  33.         ewarn "Linux kernel 2.6.15 and above contains a more recent version of this"
  34.         ewarn "module. Please consider using the in-kernel module when using"
  35.         ewarn "linux-2.6.15 or above."
  36.         ewarn
  37.     fi
  38.  
  39.     if kernel_is ge 2 6 16; then
  40.         ewarn
  41.         ewarn "This version of hostap-driver is incompatible with linux-2.6.16 and above."
  42.         ewarn "Please use the more recent in-kernel version of the hostap module when using"
  43.         ewarn "linux-2.6.16 or above."
  44.         ewarn
  45.     fi
  46.  
  47.     MODULE_NAMES="hostap(net::${S}/driver/modules)
  48.                 hostap_pci(net::${S}/driver/modules)
  49.                 hostap_plx(net::${S}/driver/modules)
  50.                 hostap_crypt_wep(net::${S}/driver/modules)
  51.                 hostap_crypt_ccmp(net::${S}/driver/modules)
  52.                 hostap_crypt_tkip(net::${S}/driver/modules)"
  53.  
  54.     if use pcmcia; then
  55.         MODULE_NAMES="${MODULE_NAMES} hostap_cs(net::${S}/driver/modules)"
  56.     fi
  57.  
  58.     BUILD_PARAMS="KERNEL_PATH=${KV_DIR}"
  59. }
  60.  
  61. src_unpack() {
  62.     unpack ${A}
  63.  
  64.     cd ${S}
  65.     epatch ${FILESDIR}/${P}.patch
  66.  
  67.     sed -i \
  68.         -e "s:gcc:$(tc-getCC):" \
  69.         -e "s:tail -1:tail -n 1:" \
  70.         ${S}/Makefile
  71.  
  72.     if use pcmcia; then
  73.         # unpack the pcmcia-cs sources if needed
  74.         pcmcia_src_unpack
  75.  
  76.         # set correct pcmcia path (PCMCIA_VERSION gets set from pcmcia_src_unpack)
  77.         if [ -n "${PCMCIA_VERSION}" ]; then
  78.             sed -i "s:^\(PCMCIA_PATH\)=:\1=${PCMCIA_SOURCE_DIR}:" ${S}/Makefile
  79.         fi
  80.     fi
  81.  
  82.     convert_to_m ${S}/Makefile
  83. }
  84.  
  85. src_install() {
  86.     if use pcmcia; then
  87.         insinto /etc/pcmcia
  88.         doins driver/etc/hostap_cs.conf
  89.     fi
  90.  
  91.     dodoc ChangeLog
  92.  
  93.     linux-mod_src_install
  94. }
  95.  
  96. pkg_postinst() {
  97.     if [ -e /etc/pcmcia/prism2.conf ]
  98.     then
  99.         einfo ""
  100.         einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
  101.         einfo "This is usually a result of conflicts with the"
  102.         einfo "net-wireless/linux-wlan-ng drivers."
  103.         einfo ""
  104.     fi
  105.  
  106.     ewarn ""
  107.     ewarn "Please note that this installation of HostAP contains support"
  108.     ewarn "for downloading binary firmware images into the non-volatile"
  109.     ewarn "(permanent) flash memory of wireless LAN cards."
  110.     ewarn ""
  111.     ewarn "Albeit being a great feature, this can lead to A DEAD CARD"
  112.     ewarn "when inappropriately used (e.g. wrong firmware)."
  113.     ewarn ""
  114.  
  115.     linux-mod_pkg_postinst
  116. }
  117.